World Deleting bug.

View previous topic View next topic Go down

World Deleting bug.

Post by Pai on Fri Jul 14, 2017 9:19 pm

Welp, the update just reset the world i was building my big city/base on. its all gone now.

If you have a pred on the planet and they eat a crew member while you teleport out. If you try to port back poof.. the flag marker disappeared.

Worried I flew back to the address to find the planet restarted and blank. Everything I built gone.


To say I'm pissed is quite the understatement.

Pai

Posts : 7
Join date : 2017-07-14

View user profile

Back to top Go down

Re: World Deleting bug.

Post by Sheights on Fri Jul 14, 2017 9:40 pm

Please post the log.

Sheights
Admin

Posts : 29
Join date : 2017-07-03

View user profile http://ssvm.forumotion.com

Back to top Go down

Re: World Deleting bug.

Post by Pai on Fri Jul 14, 2017 10:47 pm


Pai

Posts : 7
Join date : 2017-07-14

View user profile

Back to top Go down

Re: World Deleting bug.

Post by Sheights on Fri Jul 14, 2017 11:01 pm

This is not the correct Log. But worry not I have good news.
1. Returning to your world should fix it.
2. The bug I fixed today should prevent it.

Sheights
Admin

Posts : 29
Join date : 2017-07-03

View user profile http://ssvm.forumotion.com

Back to top Go down

Re: World Deleting bug.

Post by Sleeps-Fox on Fri Jul 14, 2017 11:06 pm

Sheights wrote:This is not the correct Log. But worry not I have good news.
1. Returning to your world should fix it.
2. The bug I fixed today should prevent it.
assuming the world file isn't duplicated because the main went corrupt, iv seen a similar thing in my own files where it creates a new world file to load from because the original is renamed as (XXXXXXXXX_XXXXXXXXX_XXXXXXXXX_X.world.XXXXXXXXXXXXX.fail)
avatar
Sleeps-Fox

Posts : 30
Join date : 2017-07-04
Location : *Investigating Possible issues with PredPack add-on*

View user profile

Back to top Go down

Re: World Deleting bug.

Post by Pai on Fri Jul 14, 2017 11:08 pm

When i returned to the world it was gone, but that was earlier today? Do i DL the latest build and check again?

Intersting, i see the fail world file. Can i restore it with that?

Pai

Posts : 7
Join date : 2017-07-14

View user profile

Back to top Go down

Re: World Deleting bug.

Post by SpotTea on Sat Jul 15, 2017 4:16 am

Pai wrote:When i returned to the world it was gone, but that was earlier today? Do i DL the latest build and check again?

Intersting, i see the fail world file. Can i restore it with that?
I'd say download the latest build and retry with that before other options <3
avatar
SpotTea

Posts : 3
Join date : 2017-07-03
Age : 34
Location : Thistleland

View user profile http://www.furaffinity.net/user/spottea/

Back to top Go down

Re: World Deleting bug.

Post by Pai on Sat Jul 15, 2017 4:18 pm

The latest build might have fixed it but it didn't restore the world.

So how can i fix that failed world file? It kinda has all my stuff.

Just taken off the fail tag doesn't help.

Pai

Posts : 7
Join date : 2017-07-14

View user profile

Back to top Go down

Re: World Deleting bug.

Post by Sheights on Sat Jul 15, 2017 5:32 pm

Send me the world file and I'll give it a look.

Sheights
Admin

Posts : 29
Join date : 2017-07-03

View user profile http://ssvm.forumotion.com

Back to top Go down

Re: World Deleting bug.

Post by Pai on Sat Jul 15, 2017 5:56 pm


Pai

Posts : 7
Join date : 2017-07-14

View user profile

Back to top Go down

Re: World Deleting bug.

Post by Sleeps-Fox on Sat Jul 15, 2017 7:41 pm

hopefully an easy fix and one you can only do on your end.

just incase iv got it wrong, and you need a Coordinate read out to warp to the planet again, you get that by going back to that same world ingame and then use the following command /whereami after enabling admin mode (/admin) this will create a location coordinate read out:
for example (CelestialWorld:-610539996_-60583850_-124859649_10) if im right, this will be needed at some point.

anyhow, first delete any other version of that world file that does not end with the ".world.1500071006775.fail", then edit the files name and remove the ".1500071006775.fail" from the end so it ends with just .world revert your SSVM BACK to the previous version you had been using and move 8.6 out of the mods folder, start up starbound and with a new character (to ensure you lose nothing on your main, but make sure you have the [Skip intro] toggled on), when able to use the following commands /admin then /warp  CelestialWorld:-610539996:-60583850:-124859649:10 to get back there, and Pick up every placed mod item you have, Deed's should be fine but any SSVM item you have placed down or stored, needs to be removed, i dont know if NPC's would be a problem so you might be a safe idea to remove the deeds and then place them back so you get a default NPC.

after doing this, you can exit starbound, place SSVM 8.6 back into your mods folder and move the older version out, when ingame you can just press / then the arrow up key to cycle though previous used commands for the warp command again if you cant beam from ship to the world, but! assuming youve done this right you should beable to reuse your planet as before with out it being reset though you would just have to replace all of the mod items that you removed.

iv been testing this for a bit on one of my own worlds, similar problem, and it seems to have worked for me. soo i can only wish you luck in that it works for you as well.
avatar
Sleeps-Fox

Posts : 30
Join date : 2017-07-04
Location : *Investigating Possible issues with PredPack add-on*

View user profile

Back to top Go down

Re: World Deleting bug.

Post by Proto042 on Sun Jul 16, 2017 12:27 am

managed to create a similar bug that deletes instanced worlds but won't delete space stations for some reason anyway it seems to occur when multiple vore tenants are near each other and eat an NPC who has already eaten someone or consumes someone in an egged state. Also, it seems that some vore tenants can eat others while being eaten. here is the relevant part of my log.

Proto042

Posts : 1
Join date : 2017-07-16

View user profile

Back to top Go down

Re: World Deleting bug.

Post by Pai on Sun Jul 16, 2017 2:14 am

No luck sleepy fox. And thats a damn shame. I did ever thing you suggested and it just made another fresh world, booting what i wanted back out to a fail world file.

So using the older verson of vmod wasn't it.

Pai

Posts : 7
Join date : 2017-07-14

View user profile

Back to top Go down

Re: World Deleting bug.

Post by Sheights on Sun Jul 16, 2017 2:51 am

Sorry, I can't fix it without some sort of translator, or decompiler or something. Sorry.

Sheights
Admin

Posts : 29
Join date : 2017-07-03

View user profile http://ssvm.forumotion.com

Back to top Go down

Re: World Deleting bug.

Post by Pai on Sun Jul 16, 2017 3:56 am

Well shit. =\ guess ill just cheat in what im missing.

Pai

Posts : 7
Join date : 2017-07-14

View user profile

Back to top Go down

Re: World Deleting bug.

Post by Sleeps-Fox on Sun Jul 16, 2017 6:19 am

Pai wrote:Well shit. =\ guess ill just cheat in what im missing.
aww... that's a shame, i was really hoping it would work out for you.
avatar
Sleeps-Fox

Posts : 30
Join date : 2017-07-04
Location : *Investigating Possible issues with PredPack add-on*

View user profile

Back to top Go down

Re: World Deleting bug.

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum